The root cause was a spike in background processing job requests, consuming resources on the API servers. By redistributing the workload, we have worked off the entire backlog. We will continue to monitor the fix for complications.
Posted Nov 14, 2025 - 14:03 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 13:31 EST
Update
A fix intended to improve the response time for some API-related background tasks caused failures in several real-time API tasks. We have deployed a fix to mitigate that impact.
Posted Nov 14, 2025 - 12:41 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2025 - 12:12 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2025 - 12:12 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2025 - 11:16 EST
Investigating
Many users are experiencing increased load times on platform pages. We are investigating the situation.
Posted Nov 14, 2025 - 10:56 EST
This incident affected: Public Interfaces (Application Website, ScopeStack API).