Resolved. On July 13, between approximately 2:30 PM and 5:00 PM ET, the ScopeStack web application (app.scopestack.io) intermittently returned a "website is under heavy load" error. The cause was an automated, repeating pattern of computationally intensive requests from a small number of external addresses, which saturated CPU on our front-end servers. The ScopeStack API was unaffected throughout, and API integrations continued to run normally. We have deployed two changes: one that makes the application significantly more efficient under that kind of load, and one that automatically isolates this traffic pattern before it can affect the site. We are continuing to monitor.
Posted Jul 14, 2026 - 14:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 16:59 EDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2026 - 16:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 15:32 EDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2026 - 14:48 EDT
This incident affected: Public Interfaces (Application Website).