"This website is under heavy load" Error

Incident Report for ScopeStack

Resolved

The root cause has been confirmed and CPU load is holding steady at its historic levels.
Posted Jul 14, 2026 - 22:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 20:56 EDT

Investigating

We are currently investigating this issue.
Posted Jul 14, 2026 - 20:00 EDT
This incident affected: Public Interfaces (Application Website).